[BUG] Up Studio 1.2.0.3 Crashing

Support for UP Software. To report a bug, post with a title [BUG REPORT]. To request a feature, post with a title [FEATURE REQUEST]
Post Reply
jonusx
Posts: 9
Joined: Sun May 15, 2016 8:11 pm

[BUG] Up Studio 1.2.0.3 Crashing

Post by jonusx » Wed Sep 21, 2016 4:47 pm

After updating to MacOS Sierra (10.12) UpStudio crashes immediately after opening.

iPeel
Posts: 42
Joined: Sun Dec 06, 2015 8:32 am

Re: [BUG] Up Studio 1.2.0.3 Crashing

Post by iPeel » Thu Sep 22, 2016 7:46 am

Yep', same here:

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000000
Exception Note: EXC_CORPSE_NOTIFY

Termination Signal: Segmentation fault: 11
Termination Reason: Namespace SIGNAL, Code 0xb
Terminating Process: exc handler [0]

VM Regions Near 0:
-->
__TEXT 000000010561a000-00000001058d4000 [ 2792K] r-x/rwx SM=COW /Applications/UPStudio.app/Contents/MacOS/UPStudio

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0 libsystem_c.dylib 0x00007fffa792baef strcpy + 15

madone
Posts: 16
Joined: Fri Aug 05, 2016 10:02 pm

Re: [BUG] Up Studio 1.2.0.3 Crashing

Post by madone » Fri Sep 23, 2016 12:46 am

I will add another one. Up Studio fails to launch after Mac OS Sierra upgrade

madone
Posts: 16
Joined: Fri Aug 05, 2016 10:02 pm

Re: [BUG] Up Studio 1.2.0.3 Crashing

Post by madone » Mon Sep 26, 2016 12:41 pm

Any updates to when this will be fixed?

tel
Posts: 242
Joined: Tue Feb 09, 2016 1:35 pm
Location: Australia
Contact:

Re: [BUG] Up Studio 1.2.0.3 Crashing

Post by tel » Mon Sep 26, 2016 11:56 pm

Yep Sierra upgrade kills mine, also IOS10 killed my UP Studio app

iPeel
Posts: 42
Joined: Sun Dec 06, 2015 8:32 am

Re: [BUG] Up Studio 1.2.0.3 Crashing

Post by iPeel » Tue Sep 27, 2016 3:38 pm

Can someone from Tiertime please confirm they are aware of this issue and working on a fix?

Note that there is no workaround, as the older UP! app seems to turn down the bed temperature on non-raft layers now, causing all my prints to warp.

This means until there is a fix for this My UP Box is little more than an expensive cabinet.

Tiertime-Joseph
Posts: 155
Joined: Mon Aug 27, 2012 3:45 am

Re: [BUG] Up Studio 1.2.0.3 Crashing

Post by Tiertime-Joseph » Wed Sep 28, 2016 2:36 pm

Hello,

Sorry for the problem.

We are aware of this issue, and our engineering team is working on fixing it.

Stay tuned for the update.

Thank you for your patience.

Joseph

jonusx
Posts: 9
Joined: Sun May 15, 2016 8:11 pm

Re: [BUG] Up Studio 1.2.0.3 Crashing

Post by jonusx » Wed Oct 05, 2016 5:14 pm

Just seeing if there are any updates? Thanks!

madone
Posts: 16
Joined: Fri Aug 05, 2016 10:02 pm

Re: [BUG] Up Studio 1.2.0.3 Crashing

Post by madone » Thu Oct 06, 2016 10:55 pm

It has been quite a while...Any updates on the timeframe for a fix.

ideas108
Posts: 34
Joined: Sun Jan 24, 2016 6:59 am

Re: [BUG] Up Studio 1.2.0.3 Crashing

Post by ideas108 » Sat Oct 08, 2016 11:14 am

I'm guessing Joseph will reappear after the Chinese New Year holiday in a day or so

Javier
Posts: 4
Joined: Sat Oct 08, 2016 3:06 pm

Re: [BUG] Up Studio 1.2.0.3 Crashing

Post by Javier » Sat Oct 08, 2016 3:07 pm

I contacted Tiertime through their facebook page about the issue. they said they will be releasing an update for the app this next week

tel
Posts: 242
Joined: Tue Feb 09, 2016 1:35 pm
Location: Australia
Contact:

Re: [BUG] Up Studio 1.2.0.3 Crashing

Post by tel » Sun Oct 09, 2016 2:58 am

Anyone know where we can get hold of the previous mac version to see if that works? On a positive I suppose I have started to use the mod to print with gcode from simplify3d (the app works without having to use the up software), so far the results are great. Only issue I see is it doesnt compensate for the bed levelling that is built into the UP software, meaning the bed needs to be dialled in a lot more for bigger prints.

madone
Posts: 16
Joined: Fri Aug 05, 2016 10:02 pm

Re: [BUG] Up Studio 1.2.0.3 Crashing

Post by madone » Tue Oct 11, 2016 4:14 pm

Noticed they added a new version available from the App store that fixes the issue. Have not printed with it yet but it does allow the program to run under the new os.

madone
Posts: 16
Joined: Fri Aug 05, 2016 10:02 pm

Re: [BUG] Up Studio 1.2.0.3 Crashing

Post by madone » Tue Oct 11, 2016 4:54 pm

Spoke to soon. The software runs but I am unable to load any models. I hope this gets fixed soon.

Javier
Posts: 4
Joined: Sat Oct 08, 2016 3:06 pm

Re: [BUG] Up Studio 1.2.0.3 Crashing

Post by Javier » Wed Oct 12, 2016 1:41 am

so updated my software. it works, but i cannot change my material temp settings what so ever. every time i add a custom one or even change from abs to pla.. it reverts back to ABS.

User avatar
Tiertime-Jason
Posts: 286
Joined: Mon May 05, 2014 4:31 am

Re: [BUG] Up Studio 1.2.0.3 Crashing

Post by Tiertime-Jason » Wed Oct 12, 2016 3:23 am

after setting the custom material, you need to select it again in the drop down list.

madone
Posts: 16
Joined: Fri Aug 05, 2016 10:02 pm

Re: [BUG] Up Studio 1.2.0.3 Crashing

Post by madone » Wed Oct 12, 2016 5:51 am

madone wrote:Spoke to soon. The software runs but I am unable to load any models. I hope this gets fixed soon.
After doing a little more testing I can load STL models that are saved in units of mm but not when they they are saved in units in inches. I believe the code that tries to detect that the units are in inches is crashing. It seems to load and convert the file and it looks like it is crashing when trying to display the dialog that tells you it did the conversion. It displays the model, centers it then crashes.

Post Reply