Bed temperature always reads 60.42

Support for UP mini. To report a bug, post with a title [BUG REPORT]. To request a feature, post with a title [FEATURE REQUEST]
Post Reply
randominseattle
Posts: 1
Joined: Wed Feb 15, 2017 5:27 am

Bed temperature always reads 60.42

Post by randominseattle » Sat Mar 18, 2017 7:56 pm

In UP Studio 1.6.0 (170) for Mac, the platform temperature of my UP! Mini always reads 60.42C, even when it's stone cold. The heater does work (if I select preheat in the Maintenance screen the platform does get hotter to the touch), but the software always thinks its the same temperature. No matter what preheat time I select in the preferences, printing always starts as soon as the nozzle is up to temp.

I know there are some features of the software that don't work with the original Mini...is this one of them, or is there something off with the temperature sensor in the platform?

dlimb
Posts: 1
Joined: Tue Mar 28, 2017 6:51 pm

Re: Bed temperature always reads 60.42

Post by dlimb » Tue Mar 28, 2017 6:54 pm

I'm having exactly the same issue. I just got my unit a couple of days ago, downloaded UP Studio 1.6.1.2 for Windows, tried out the preliminary testing and noticed that platform temperature is stuck at 60.42. I am currently downloading an older version of the UP Studio, hopefully that solves the problem.

Scirocco
Posts: 7
Joined: Tue Feb 02, 2016 5:22 pm

Re: Bed temperature always reads 60.42

Post by Scirocco » Wed Apr 12, 2017 9:36 am

Hi guys,

the UP Mini doesn't have any temperature sensor on the heat bed. The Printer only knows about the corresponding switch (I guess MOSFET) on the mainboard. Since the heatbed has a temperature switch integrated and there is no feedback to the mainboard, the printer never knows, when the temperature is reached. That is why UP Studio only shows this weird temperature.
UPMini.PNG
UPMini.PNG (22.05 KiB) Viewed 2836 times
This is why I modded my printbed with two LEDs and two resistors, so I can see, wether the heatbed is switched on or off and wether the Temperature is reached.
For the switch on LED I connected a sufficient resistor and LED to the supply connectors on the bed. There are two potentials: 12V and ground.
The other LED for the reached temperature I connected with a sufficient resistor to the two leads of the temperature switch. Since the switch cuts off connection as soon as the switching temperature is reached, the voltage drops throug the LED.
Like this I can see easily if the heatbed is switched on (orange) and if the temperature is reached (green).
UPminiLED.jpg
UPminiLED.jpg (199.65 KiB) Viewed 2836 times

Post Reply