Up Mini Blinking On Power-up

Support for UP mini. To report a bug, post with a title [BUG REPORT]. To request a feature, post with a title [FEATURE REQUEST]
Post Reply
Nortiz2002
Posts: 3
Joined: Sat May 09, 2015 11:34 pm

Up Mini Blinking On Power-up

Post by Nortiz2002 » Sun May 10, 2015 9:25 pm

Hey All,

I have an Up Mini that has been working flawlessly over the past 2 months I've had it, printed a handful of smaller items no problem. Today I tried to power on the unit and the light up front on the Initialize button blinks blue, then red, the nothing, then repeats. The blue stays on a bit longer, the red flashes quickly, and then no light at all....then repeat. I notice the LED light on the power supply also blinks. Has anyone come across this before? I've searched the forum for similar issues but no one seems to have this exact issue. I've tried resetting, installing the software over again..won't link to the computer at all. Any help would be appreciated, it is a newer machine and I'm just a little disappointed that it's causing me trouble already. Thanks for the help All!

mb20music
Posts: 375
Joined: Thu Feb 14, 2013 1:35 am
Location: USA

Re: Up Mini Blinking On Power-up

Post by mb20music » Mon May 11, 2015 3:53 am

Sounds to me like a bad CPU board or bad motherboard, did you purchase this printer new? if so you do have a 12 month warranty from the manufacturer.

I would contact the place of purchase or send an e-mail to support@pp3dp.com

Nortiz2002
Posts: 3
Joined: Sat May 09, 2015 11:34 pm

Re: Up Mini Blinking On Power-up

Post by Nortiz2002 » Mon May 11, 2015 12:12 pm

Sigh, was afraid of that being a possiblity. I emailed customer support about 2 days ago, having gotten a reply but probably because of the weekend. Hoping I hear something today :|

Nortiz2002
Posts: 3
Joined: Sat May 09, 2015 11:34 pm

Re: Up Mini Blinking On Power-up

Post by Nortiz2002 » Sat May 16, 2015 6:53 pm

Just an update, contacted customer service and rep has gotten back to me, but I haven't heard back since Tuesday. I figured I'd try to power it up just to see what happens, and it actually powered up like normal and I got it to connect to my mac. I set an item up to print as a test and it got half way through before it stopped and the light up front started blinking. I powered it down, and when I went to power it back up it started again with my original problem of instantly blinking blue, red, nothing, repeat. Sometimes now it just blinks blue upon power up. Not sure if this info is useful to anyone, in case anyone else was having a similar issue.

Here's hoping customer service gets back to me soon!

Post Reply