Page 1 of 1

Printer goes mad after completion - possible netfabb .stls?

Posted: Mon Mar 11, 2013 8:23 am
by mechatanuki
Hey guys, having a VERY weird issue that I could use some insight into - here's the breakdown:
I teach a small 3D printing club, the students use sculptris to design little figurines. This .obj file is then converted to a .stl using meshlabs.

I've been printing these files fine, but lately they've wanted to add more spheres to the design meaning more shells, and the UP software separates these instead of gluing them together in the print. To remedy this, I've been feeding the .st's through the netfabb cloud service to create one shell. The print goes flawlessly - TILL it's completed then the machine 'slowly' moves down again towards the print, usually collides and will be extruding and moving as if trying to print something! :shock:

Printer is always disconnected from the laptop as soon as the print starts.

So - has anyone else had this occur? Could the netfabb cloud service be doing more harm than good? I've been looking for an alternate free method to combine the shells with no success. :|

Re: Printer goes mad after completion - possible netfabb .st

Posted: Mon Mar 11, 2013 8:19 pm
by D3rax
You could try netfabb studio basic ( http://www.netfabb.com/download.php ) instead of the cloud service. I use it all the time to repaire and cut stl's and to convert files to stl. Works fine for me :)

Re: Printer goes mad after completion - possible netfabb .st

Posted: Tue Mar 12, 2013 10:43 pm
by roller
I suspect it's not netfabb - I've used the cloud and studio version (cloud produces much cleaner results) without such an incident. There is a weird bug sometimes with the Up!s where they try and print an old print after one completes. It seems only a certain prints would trigger the second one to print. In my case it the second print was the remainder of a print I cancelled mid way through and it kept happening until I let the second print complete - since then it's never happened again. Maybe you could pause as the first print ends and pull out the perfboard and let it continue - a waste of filament I know. You could cut your filament off so it doesn't get wasted but a long print without filament might cook the ABS left in the nozzle and result in the need for a clean later.

I am sure there are other solutions though - maybe a search of the forums for this issue might yield an answer.

Re: Printer goes mad after completion - possible netfabb .st

Posted: Wed Mar 13, 2013 12:41 pm
by mechatanuki
Thanks for the suggestions guys! You might be right roller, I had it occur today on a print straight from thingiverse - I had cancelled the previous print halfway through as it was just for a demo and taking too long. Does anyone know if I can format the SD card or does it have something crucial on it? Would be nice to erase and remove any possibility of old prints being 'restarted' at the end of a successive print which seems to be the bug here. :roll:
@ D3rax i'm only using the cloud service to combine shells easily and free - I couldn't work out a way to do it with the studio basic software I downloaded - seemed disabled for the free version?

Re: Printer goes mad after completion - possible netfabb .st

Posted: Thu Mar 14, 2013 4:25 am
by roller
Previous versions of the free studio version of Netfabb were better and more powerful. It's been trimmed back in recent versions. no idea of a source for older editions. Would like some older (Mac) versions myself.

Re: Printer goes mad after completion - possible netfabb .st

Posted: Sat Mar 16, 2013 1:12 am
by mechatanuki
I've worked out a pretty good fix without needing to let the "ghost" print continue, if you fire up the UPinspector (only works if the main up software is closed) and do the SD card check, it'll send loads of blank commands and seems to override any old prints. I haven't had any problems since, done ~ 10 prints or so.

And yep - can only combine shells in the professional version now, will have to keep searching. :(

Re: Printer goes mad after completion - possible netfabb .st

Posted: Sun Mar 17, 2013 11:21 am
by roller
Handy tip ... Be nice if we had such an easy fix for Mac users too.

Re: Printer goes mad after completion - possible netfabb .st

Posted: Sat May 18, 2013 5:07 pm
by Foreshadower
I have the same problem, it´s really annoying to end up with a damaged part after hours of printing it. Is there any way to use the UPinspector on a mac? I cant find the file..

Re: Printer goes mad after completion - possible netfabb .st

Posted: Fri Oct 25, 2013 4:41 pm
by clementine
I'm having the same issue with my UP! Mini and a Macbook Pro.

PP3DP FIX THIS, i'm dead tired of having big prints being destroyed after printing for 8 hours because of a stupid software problem!

Re: Printer goes mad after completion - possible netfabb .st

Posted: Mon Oct 28, 2013 5:28 am
by roller
If you don't have access to a Windows PC try reflashing the firmware.

Re: Printer goes mad after completion - possible netfabb .st

Posted: Fri Nov 22, 2013 4:52 pm
by Ronpitt
I have the exact same problem, can not figure it out for the life of me. Getting so frustrated!

Re: Printer goes mad after completion - possible netfabb .st

Posted: Sat Nov 30, 2013 11:55 pm
by marto
Remove the SD card and do a full format on your pc. Should write all zeros to it which will remove any stray commands which have been written.


Steve

Re: Printer goes mad after completion - possible netfabb .st

Posted: Sun Dec 01, 2013 1:14 am
by wackojacko
Also make sure you are using the latest Windows or MAC versions. I haven't seen this issue since 2.0