Up Plus 2 just damaged itself

Support for UP Plus and UP Plus 2. To report a bug, post with a title [BUG REPORT]. To request a feature, post with a title [FEATURE REQUEST]
Post Reply
Posts: 18
Joined: Wed Jan 15, 2014 12:07 pm

Up Plus 2 just damaged itself

Post by Helicopter » Thu Jan 23, 2014 1:51 pm

Just when I really started to love it, my UP decided to self destruct. Its only 2 weeks old... :cry:

First, during a Nozzle Height detect the platform just kept going after the switch made contact and crashed into the nozzle with 2 audible clicks of the belt jumping. It reported 139mm Nozzle Height (real one is about 134.8 measured with a feeler gauge). Alright, so after I confirmed the connectors are plugged in fully and tight (they were), I cleaned the switch, because I thought something might be blocking the contact (even thought nothing was there). Another try, another crash, 4 belt jump clicks this time. Reported 140mm Nozzle Height, and then: disconnected! Couldn't reconnect anymore. It does initialize with the button, but no USb connection.

I ususally dont use the height detect at all since it's wildly inaccurate compared to a feeler gage, and its values vary a lot, too. Why, oh why did I have to do it today?!

Then, after I let it sit there for 1/2 hour with the Nozzle Height / Autolevel switch cable disconnected (removed it in case the possibly faulty switch was somehow interfering with the electronics) but initialized via button, I heard a Windows USB sound on my PC. It reconnected! I could initialize it from the software again as well. But, as soon as I reconnected the switch cable (just the cable to the printer, no switch on the other end yet, poof, it disconnected again. Havent been able to reconnect since.

:cry: :cry: :cry:

Just contacted the German reseller, who was up to now extremely friendly and helpful, but is not willing to provide phone support for this, they only do actual problem support via email :roll: .
Since I really need it I'm hoping to be able to reconnect, then NOT touch that cable and start printing again at least until I hear back from support or maybe someone here can help out.

For what I've read, the disconnected but still initializing symptoms are consistent with a fried CPU.
Now, since it disconnected when the platform drove against the nozzle long and hard, I could kind of imagine a board getting fried when a motor pulls a lot of power driving against the nozzle.
Would that make sense or have motors nothing to do with the CPU?

On the other hand, the non-working switch was there before and I'm not sure if this is just all part of the same error rather than a faulty switch causing a power spike causing some fried board.

The fact that I was briefly able to reconnect though is what is most startling to me.

Any HELP ? (Help, pleaaaase!!)

User avatar
Posts: 667
Joined: Fri Nov 12, 2010 5:46 am

Re: Up Plus 2 just damaged itself

Post by wackojacko » Thu Jan 23, 2014 5:45 pm

I would agree that your CPU needs replacing

Need help with your printer, check out our Youtube channel.
https://www.youtube.com/user/3dprinting ... /playlists

Posts: 18
Joined: Wed Jan 15, 2014 12:07 pm

Re: Up Plus 2 just damaged itself

Post by Helicopter » Thu Jan 23, 2014 6:47 pm

Well whatever it is, the German Distributor noDNA just told me -by email, as I said, no phone support- I will need to send it in, and it will take them 2-4 weeks to repair it! :o

They say chinese new year is preventing them from doing anything. Wow, thats why I paid a few hundred $ extra and got it from a local dealer - only to still depend on china for support. Its just 12 days old and alreday dead, yet they wont exchange it for a new one, nor do they offer a temporary replacement during the ridiculous repair time (not even for a rental fee, just not possible).

Anyway, I'm looking at getting another UP since I just cant have 2-4 weeks downtime right now. Any Hints on a -dependable!- reseller who can ship to Germany reasonably quick? I'd rather pay a bit more and actually get good support. Thought the same when buying at noDNA, but well... :(

Posts: 16
Joined: Mon Jul 11, 2011 7:54 pm

Re: Up Plus 2 just damaged itself

Post by Rhenium » Fri Jan 24, 2014 8:52 pm

Helicopter: I'm sorry that I cannot offer any help. I am concerned about the CPU burning out, I have had a similar issue with the original Up Plus, and am saddened to hear that it is also a problem with the Up Plus 2.

Posts: 3
Joined: Fri Dec 06, 2013 12:33 pm

Re: Up Plus 2 just damaged itself

Post by baxter888 » Mon Feb 03, 2014 6:35 pm

i found the problem of this error.

after the same behaviour of my UP! Plus 2 like here: http://www.pp3dp.com/forum/viewtopic.php?f=18&t=41414
and then the Sensor Connection Error i searched the cause of this problem.

the jack connection cable is the problem! If you turn, warp or move the cable a little bit or with more force, i can reproduce the problem.
i think, the cable has a bad quality and i have to say, that perhaps i have made a fault, because i not disconnected the cable while printing. I can be, that the connection between the jack and the cable is moltedn by the heat of the platform.

if i have the sensor connection error, i turn, warp the cable a little bit, and everything works great. But it is nerved, therefore i will replace the cable.

please give a feedback, if it also works to you.


Posts: 18
Joined: Wed Jan 15, 2014 12:07 pm

Re: Up Plus 2 just damaged itself

Post by Helicopter » Tue Feb 04, 2014 11:11 pm

Hey Baxter888,

I wrote some more info in http://pp3dp.com/forum/viewtopic.php?f=18&t=4619.

I can confirm, that the cable is probably crap, and it is likely that it caused the nozzle height detect to fail as mentioned above. On my sesond UP, when I tried the nozzle height detect and autolevel sensors, they didn't work although properly connected. Pulled the plugs and switched them out, it works. Switch them back, doesn't work anymore. However, I just stopped using both sensors alltogether, since nozzle height detect is wildly inaccurate anyway, and autolevel can easily be replace with a (again, more accurate) dial indicator, that with a printed special part can snap right into the place of the autolevel sensor.

I'm no longer sure the aforementioned sensor crash is the cause of the actual CPU destruction though, since I have strong suspicions this has to do with ESD, and it may have been either a mere coincidence this happened during the nozzle-sensor crash or this caused an ESD to the board from the improperly grounded part in the x-axis.

Post Reply