About to toss my printer in the garbage. :(

Share your experience with Cetus. You can also visit www.cetus3d.com
Post Reply
Joined:Mon Mar 25, 2019 6:43 pm
About to toss my printer in the garbage. :(

Post by telarium » Wed May 08, 2019 9:54 pm

I'm at a loss for while my Cetus MKII Extended clogs every single time now. Here's a link to a photo of what happens, but you can see the filament starts to bunch up between the extruder and the nozzle.


What I've tried so far:

Unclogged the nozzle.
Replaced the nozzle.
Tried several different filaments
Tried temp ranges from 210 to 290
Re-calibrated the nozzle height
Tried different slicers
Cleaned out the extruder gears
Tried different filament spool holders
Made sure the filament can move freely from the spool to the extruder

I have no idea what to do other than completely replace the entire extruder and print head. But I haven no idea that will even help at this point.

Joined:Mon Feb 18, 2019 6:14 am

Re: About to toss my printer in the garbage. :(

Post by Tiertime_Ocean » Thu May 09, 2019 3:57 am

Dear Customer,

Please share your MKII SN with us. And we check it's in warranty or not?
We will dispatch a new extruder for you if it's in warranty.
And also you can contact us by Email: support@tiertime.com
Please feel free to contact us if you have any problems.

Joined:Fri Mar 08, 2019 3:34 pm

Re: About to toss my printer in the garbage. :(

Post by Arnold » Fri May 10, 2019 1:54 am

I did have a clog on the 0.2 nozzle, although it's not as bad as what you experienced but what I did was -

1. Withdraw the filament
2. Do an Extrude filament (without any filament) 3 times and the remaining filament starts to flow from the nozzle
3. Put in the filament and Extrude filament, this time it flows evenly and smoothly.

The other key is the temperature, specially when changing from PLA to PETG or vice versa.

Technology Salad
Joined:Tue Aug 28, 2018 8:10 pm

Re: About to toss my printer in the garbage. :(

Post by Technology Salad » Wed May 22, 2019 12:25 am

Was viewing the photo you linked a few days ago, but no longer have access to the photo you linked @telarium . I remember seeing something blue attached to the extruder motor, and a pic of the gear grooves in the filament.

The grooves from the gear in the filament are far too deep and do not have enough structural strength to push through the nozzle into the heat zone.

You either have an over-heating extruder motor which is heating the filament too much before it gets to the heat-zone in the nozzle or too much pressure forcing the gear to dig deeper into the filament which then is too weak to reliably make the rest of the journey.

I recommend removing anything extra from the extruder motor and even removing the electronics hat (3D printed cover) and then perform @Arnold 's instructions or your own method of unclogging a nozzle. Then try printing something.

Hope this helps you!

Post Reply