Can't Initialize

Support for UP Plus and UP Plus 2. To report a bug, post with a title [BUG REPORT]. To request a feature, post with a title [FEATURE REQUEST]
Post Reply
mjrichmo
Posts: 2
Joined: Wed Sep 21, 2011 2:26 pm

Can't Initialize

Post by mjrichmo » Sun Aug 11, 2013 2:49 pm

I'm having trouble initializing my UP Plus 2 on mac and PC....says printer is disconnected, even though it is powered on and connected. When I try on the PC to load the drivers it doesnt let me, saying that they arent the correct ones.

On both OS, it doesnt say the printer is connected when in UP software. When I try to initalize it won't let me because it doesnt think a printer is connected.

Tried emailing customer support multiple times with no response.

Is this common from the PP3DP manufacturer? I'm pretty unimpressed.

Tiertime-Edward
Posts: 206
Joined: Tue Sep 07, 2010 9:15 am

Re: Can't Initialize

Post by Tiertime-Edward » Mon Aug 12, 2013 1:36 am

What is your PC system, windows 8?

lukeott
Posts: 53
Joined: Wed Jun 26, 2013 6:43 am

Re: Can't Initialize

Post by lukeott » Mon Aug 12, 2013 7:25 am

I've had this same issue twice on my Up Plus 2 (under Win 8). Both times I tried rebooting pc, checking drivers, etc, and both times it was fine after I turned the Up off an on again.
I should have remembered the sage advice from the IT Crowd:
http://youtu.be/nn2FB1P_Mn8
:D

Hope this works for you in the short term, but maybe there is a bigger issue which needs to be resolved with these printers.

Post Reply